View Issue Details

IDProjectCategoryView StatusLast Update
0000857SOGo Connectorpublic2011-03-08 08:26
Reporterkarora Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinuxOSDebianOS Version5 (Lenny)
Product Version 
Target VersionFixed in Version 
Summary0000857: Lightning CardDAV plugin wants old syntax for WebDAV Sync report
DescriptionThe CardDAV plugin for lightning expects the XML from the server to use DAV::sync-response elements. The definition of this report changed in draft -03 to use simple DAV::response elements in line with normal REPORT and PROPFIND responses.

See http://tools.ietf.org/html/draft-daboo-webdav-sync-03

In particular, see point (4) under 'Changes in -03' in Appendix A.

Quite likely the plugin will need to allow for either DAV::response or DAV::sync-response for a period of time as servers and clients catch up with the latest draft.
Steps To Reproduce1) Use the Inverse CardDAV plugin to connect to a DAViCal addressbook via CardDAV, using DAViCal 0.9.9.3 or later.

2) Observe that you do not get any contact information on a synchronise action.

3) Change the DAViCal configuration to add the setting:

   $c->use_old_sync_response_tag = true;

4) Repeat step (2) but this time see all the happy contacts appear :-)
Additional InformationI'm the author of DAViCal CalDAV server. I just released version 0.9.9.3 with the dodgy configuration setting workaround for this issue as outlined above.

It seems exceedingly likely that this bug has a corresponding server-side bug in SOGo... :-)

Regards,
Andrew McMillan.
TagsNo tags attached.

Relationships

duplicate of 0001098 resolvedwsourdeau GroupDavSynchronizer: obsolete DAV:sync-response after DAV:sync-collection request? 

Activities

karora

karora

2011-01-20 14:41

reporter   ~0002038

I've now written an Android CalDAV client, which I was attempting to test against SOGo server last night, and I can confirm that the SOGo server also suffers from the same problem, sending 'sync-response' elements instead of 'response' elements.

A new draft has been issued, including minor updates, but it is very unlikely that the basic response will change further. See:

http://tools.ietf.org/html/draft-daboo-webdav-sync

Regards,
Andrew McMillan.
fedel

fedel

2011-01-26 10:59

reporter   ~0002053

I ran into the exact same issue with the Sogo connector for Thunderbird 3 and reported it as bug 0001098. Sorry, I was not aware of this report. I attached a patch to 0001098 which can be applied to the latest Thunderbird connector nightly. The patch resolves the issue on my setups.

Regards,
Frank
ludovic

ludovic

2011-03-08 08:26

administrator   ~0002216

karora - can you try the patch from http://www.sogo.nu/bugs/view.php?id=1098 and tell us if it works well for you?

Issue History

Date Modified Username Field Change
2010-09-25 09:01 karora New Issue
2011-01-20 14:41 karora Note Added: 0002038
2011-01-26 10:59 fedel Note Added: 0002053
2011-02-04 11:40 ludovic Project Lightning (Inverse Edition) => SOGo Connector
2011-03-08 08:26 ludovic Note Added: 0002216
2011-03-08 08:26 ludovic Relationship added duplicate of 0001098
2011-03-08 08:26 ludovic Duplicate ID 0 => 1098
2011-03-08 08:26 ludovic Status new => resolved
2011-03-08 08:26 ludovic Resolution open => duplicate
2011-03-08 08:26 ludovic Assigned To => ludovic