View Issue Details

IDProjectCategoryView StatusLast Update
0001148SOGo Integratorpublic2011-02-23 11:52
Reporteralessio Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionnot fixable 
Product Version3.104 
Summary0001148: Thunderbird losts key press entering email address
Description

Myself and several other users of Thunderbird v 3.1 (Connector / Integrator 3.104 & Lightning 1.b2.104i) are reporting problems when entering in an email address when composing a new mail.

If the email is not already stored in our address book, and we're composing a new email to a new recipient, every other key press fails to produce a letter. So if I type, "foo@bar.com" I will have to type "f" then "o" twice for the o to show up and then for every subsequent letter it is like that. Thunderbird lose letters.

More quick composing and more press fails.

TagsNo tags attached.

Activities

aschild

aschild

2011-02-23 01:47

reporter   ~0002148

I think this happens when TB does search for
auto completing the email address via the configured ldap
sources.

If they don't answer fast enough, then we see "lost"
characters in the email addresses we enter.

alessio

alessio

2011-02-23 04:20

reporter   ~0002149

"I think this happens when TB does search for
auto completing the email address via the configured ldap
sources."
If it's true, i should stop this problem disabling "Remote Address Book" from composing preferences.

wimmer

wimmer

2011-02-23 08:45

reporter   ~0002150

Yes, our users using TB3.1 have the same problem.
Some of them downgraded back to TB2, where this trouble doesn't exist.
Disabling of "Remote Address Book" is not the right way because users lost advantage of LDAP Address Book.

aschild

aschild

2011-02-23 09:10

reporter   ~0002151

@wimmer: But does disabling the remote address book "solve" the problem ?

If yes, then we are sure that this is causing the problem.
If no, then something else might cause these lost key strokes.

wimmer

wimmer

2011-02-23 09:27

reporter   ~0002152

I'm not sure what causes this problem.

  • TH2 + extensions + "Remote Address Book" => works nice
  • TH3 + using of remote ldap server => works nice
  • TH3 + extensions + "Remote Address Book" => works bad

When I disable "Remote Address Book" from TH3 + extensions, TH3 uses it all the time. I think Integrator overrides that disabling.

wsourdeau

wsourdeau

2011-02-23 11:51

viewer   ~0002153

The bug is actually in Thundebird: https://bugzilla.mozilla.org/show_bug.cgi?id=608041

It's probably going to be solved around august 2038.

What we do to work around the issue is raise the search timeout like this:

pref("sogo-connector.autoComplete.delay", 1300);

wsourdeau

wsourdeau

2011-02-23 11:52

viewer   ~0002154

Closed as the bug really is in Thunderbird. See references and work-around above.

Issue History

Date Modified Username Field Change
2011-02-22 11:50 alessio New Issue
2011-02-23 01:47 aschild Note Added: 0002148
2011-02-23 04:20 alessio Note Added: 0002149
2011-02-23 08:45 wimmer Note Added: 0002150
2011-02-23 09:10 aschild Note Added: 0002151
2011-02-23 09:27 wimmer Note Added: 0002152
2011-02-23 11:51 wsourdeau Note Added: 0002153
2011-02-23 11:52 wsourdeau Note Added: 0002154
2011-02-23 11:52 wsourdeau Status new => closed
2011-02-23 11:52 wsourdeau Resolution open => not fixable