SOGo | BTS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001561SOGoBackend Address Bookpublic2011-12-31 00:402012-03-26 09:25
Reportermjd 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.3.11 
Target VersionFixed in Version1.3.14 
Summary0001561: VCards with percent encoded symbols in the uid are unavailable over caldav/webdav.
DescriptionAt least for VCards (ICals are untested), percent encodable characters in the uid cause the files to be unaccessible over webdav.

For example, take the uid:
collected=3A_avtek_assistant_-_ww_avasst

Accessing the url using webdav works as expected. However, the filename reported is:
collected%3D3A_avtek_assistant_-_ww_avasst

Attempting to access this uid fails to work.
Additional InformationI think when bug 1383 was fixed, it started percent encoding the filenames reported, but I believe they are supposed to remain as-is in this case.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0003641)
mjd (reporter)
2012-03-25 01:48

As of version 1.3.14 (and maybe 1.3.13), I believe the issue is solved. When accessing the escaped version of the url, the correct result is returned. I've manually verified this with a webdav client. As such, this issue can be closed as resolved.

- Issue History
Date Modified Username Field Change
2011-12-31 00:40 mjd New Issue
2012-03-25 01:48 mjd Note Added: 0003641
2012-03-26 09:25 Christian Mack Status new => closed
2012-03-26 09:25 Christian Mack Resolution open => fixed
2012-03-26 09:25 Christian Mack Fixed in Version => 1.3.14


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker