View Issue Details

IDProjectCategoryView StatusLast Update
0001703SOGo Native Outlook Compatibility (obsolete)public2012-05-20 22:17
ReporterFleOxm Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
Product Versiontrunk 
Target VersionFixed in Version 
Summary0001703: Samba crash due to IMAP4 Connection Error
DescriptionHello

I ve installed SOGO beta5 on a debian machine amd64 with postfix/cyrus and ldap authentication.

All works fine using SOGo, thunderbird or funambol.

Samba4 and openchange provisionning is ok and i can join my domain.
I can configure outlook and it find my account.
However, when i try to launch Outlook (2007 or 2010), samba crash with the following error :

kernel: [353705.641880] samba[19469]: segfault at 18 ip 00007f707b9e7b61 sp 00007fff0bc12f58 error 4 in libc-2.13.so[7f707b968000+17d000]

my samba log :
[SOGo: sogo_backend_list_contexts:196]
2012-03-16 11:28:29.195 samba[19469] registered class 'MAPIStoreNotesContext' as handler of 'notes' contexts
2012-03-16 11:28:29.195 samba[19469] registered class 'MAPIStoreFallbackContext' as handler of 'fallback' contexts
2012-03-16 11:28:29.195 samba[19469] registered class 'MAPIStoreCalendarContext' as handler of 'calendar' contexts
2012-03-16 11:28:29.195 samba[19469] registered class 'MAPIStoreOutboxContext' as handler of 'outbox' contexts
2012-03-16 11:28:29.195 samba[19469] registered class 'MAPIStoreTasksContext' as handler of 'tasks' contexts
2012-03-16 11:28:29.195 samba[19469] registered class 'MAPIStoreContactsContext' as handler of 'contacts' contexts
2012-03-16 11:28:29.195 samba[19469] registered class 'MAPIStoreMailContext' as handler of 'mail' contexts
Mar 16 11:28:29 samba [19469]: <0x02B5F7B0[SOGoMAPIFSFolder]:(null)> directory: /usr/local/samba/private/mapistore/SOGo/username/message/fallback/
Mar 16 11:28:29 samba [19469]: [WARN] <0x0x276c850[SOGoWebDAVAclManager]> entry '{DAV:}write' already exists in DAV permissions table
Mar 16 11:28:29 samba [19469]: [WARN] <0x0x276c850[SOGoWebDAVAclManager]> entry '{DAV:}write-properties' already exists in DAV permissions table
Mar 16 11:28:29 samba [19469]: [WARN] <0x0x276c850[SOGoWebDAVAclManager]> entry '{DAV:}write-content' already exists in DAV permissions table
2012-03-16 11:28:29.201 samba[19469] WARNING: IMAP4 connection pooling is disabled!
Mar 16 11:28:32 samba [19469]: [ERROR] <0x0x43017d0[NGImap4ConnectionManager]> IMAP4 login failed:
  host=127.0.0.1, user=username, pwd=yes
  url=imap://username@127.0.0.1/
  base=(null)
  base-class=(null))
  = <0x0x251d6f0[NGImap4Client]: login=username(pwd) socket=<NGActiveSocket[0x0x453b550]: mode=rw address=<0x0x32e5620[NGInternetSocketAddress]: host=localhost port=37442> connectedTo=<0x0x4301a50[NGInternetSocketAddress]: host=127.0.0.1 port=143>>>
2012-03-16 11:28:32.213 samba[19469] Note(NGImap4Connection): using '/' as the IMAP4 folder separator.
Mar 16 11:28:32 samba [19469]: <0x03D0FE40[SOGoMailAccount]:0> renewing imap4 password
Mar 16 11:28:32 samba [19469]: [ERROR] <0x03D0FE40[SOGoMailAccount]:0> no IMAP4 password available
Mar 16 11:28:32 samba [19469]: [ERROR] <0x03D0FE40[SOGoMailAccount]:0> Could not connect IMAP4
Segfault Error

I accept any help to investigate this error..

Thanks
TagsNo tags attached.

Activities

2012-03-20 05:18

 

gdb.txt (Attachment missing)

2012-03-20 05:18

 

samba-log.txt (Attachment missing)
FleOxm

FleOxm

2012-03-20 05:27

reporter   ~0003600

Last edited: 2012-03-21 13:02

After a few tries, IMAP4 was a wrong clue. I no longer met this error, but only Segfault error.

I join some log file..

Thanks

Edit 21/03 : add Valgrind log, trying to read it

2012-03-21 13:02

 

valgrind.txt (Attachment missing)
FleOxm

FleOxm

2012-03-28 10:23

reporter   ~0003666

Last edited: 2012-03-28 10:26

After an update to Openchange1.0, Samba Alpha 18, and last revision of SOPE/SOGo/Openchange Connector, i always have a crash when i launch Outlook..

Normally, it should be authenticate against IMAP server but it seems that it doesn't send my password (from ldap).

I don't know why, during one try and with the same configuration, i could launch Outlook, folders were created in mapistore and Openchange.ldb was updated.
However, samba finally crashed.

i continue to investigate.. valgrind trace and other logs are the same

(sorry for my english..)

wsourdeau

wsourdeau

2012-05-20 22:17

viewer   ~0003929

This is not a bug. As stated in the documentation, login must be allowed with any password from the OpenChange host (and only from it). This is a limitation of OpenChange/SOGo due to the fact that we cannot know the user password, hence we cannot use it again when authenticating to an IMAP server.

Issue History

Date Modified Username Field Change
2012-03-16 06:44 FleOxm New Issue
2012-03-20 05:18 FleOxm File Added: gdb.txt
2012-03-20 05:18 FleOxm File Added: samba-log.txt
2012-03-20 05:27 FleOxm Note Added: 0003600
2012-03-21 13:02 FleOxm Note Edited: 0003600
2012-03-21 13:02 FleOxm File Added: valgrind.txt
2012-03-28 10:23 FleOxm Note Added: 0003666
2012-03-28 10:26 FleOxm Note Edited: 0003666
2012-05-20 22:17 wsourdeau Note Added: 0003929
2012-05-20 22:17 wsourdeau Status new => closed
2012-05-20 22:17 wsourdeau Resolution open => no change required