View Issue Details

IDProjectCategoryView StatusLast Update
0002323SOGo Connectorwith SOGopublic2013-06-25 13:08
Reportermmerlone Assigned To 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0002323: Unable to save addressbook preference on Thunderbird
DescriptionSet a sogo server 2.0.5a with updates.php, sogo-integrator-17.0.5, sogo-connector-17.0.5. I have set on sogo.conf:
SOGoUserSources = (
    {
        type = ldap;
        id = catalogo;
        displayName = "CatalogoA1";
        canAuthenticate = NO;
        isAddressBook = YES;
        CNFieldName = cn;
        UIDFieldName = uid;
        baseDN = "dc=a1,dc=ind";
        bindDN = "cn=admin,dc=a1,dc=ind";
        bindPassword = oops;
        hostname = "ldap.a1.ind.br";
    },
    {
        type = ldap;
        id = logins;
        displayName = "Logins";
        canAuthenticate = YES;
        isAddressBook = NO;
        CNFieldName = cn;
        IDFieldName = uid;
        UIDFieldName = uid;
        baseDN = "ou=People,dc=a1,dc=ind";
        bindDN = "cn=admin,dc=a1,dc=ind";
        bindPassword = oops;
        hostname = "ldap.a1.ind.br";
    }
    );
On web interface addressbook search works as expected. But on Thunderbird the preference on wich LDAP server (CatalogoA1) to search for addresses does not survive a restart, returning with a blank choice. If set again it works until next application restart.
Additional InformationTested on Ubuntu 12.10, Windows 8 and Windows 7 with Thunderbird 17 ESR and non-ESR.
TagsNo tags attached.

Relationships

related to 0000829 resolvedludovic SOGo Auto-complete attendees not search in LDAP address book 

Activities

2013-05-15 10:17

 

2013-05-15_11-14-58.png (Attachment missing)
alessio

alessio

2013-05-30 04:28

reporter   ~0005618

I can confirm this bug, how can i fix it with a workaround?
piviul

piviul

2013-05-31 03:29

reporter   ~0005620

I can confirm this bug too but with a very little differencw between linux and windows. In linux when I open thunderbird the preferred remote address book is not set (blank choice as in the above attacched file) but in windows is the sogo default address book. In both cases (linux and windows) every remote address book selected in preferences is forgotten when the client is reopened.

I hope someone can find early a workaround because using TB sogo plugin with only local address books is not so collaborative!

Have a great day

Piviul
Christian Mack

Christian Mack

2013-05-31 07:30

developer   ~0005621

Please check your site.js for Integrator as per Bug 0000829
piviul

piviul

2013-05-31 09:29

reporter   ~0005622

Ok, as workaround I have commented the row

pref("sogo-integrator.autocomplete.server.urlid", "public");

Now I can choose which remote address book to use and thunderbird remember it after a restart. Thanks a lot

Piviul
mmerlone

mmerlone

2013-06-03 08:04

reporter   ~0005625

Correcting site.js with a catalog name as per bug 0000829 does not work, still the same behavior. When going to about:config it says is using "CatalogoA1" and tha it is the default.
The above workaround works, I can set "CatalogoA1" on TB ui and it stays between restarts.
IMHO the docs should cite site.js and when it needs to be corrected, and make that pref work, which is not.
ludovic

ludovic

2013-06-03 08:18

administrator   ~0005626

Try creating a new profile with the CORRECT site.js.
Christian Mack

Christian Mack

2013-06-03 08:25

developer   ~0005627

You should use the "id" value not the "displayName" value in your site.js.
So in the above SOGo config it would be "catalogo" instead of "CatalogoA1".
piviul

piviul

2013-06-03 08:49

reporter   ~0005628

Ok, putting the id value in pref("sogo-integrator.autocomplete.server.urlid", "id value") of site.js seems to solve the problem.

Furthermore in my humble opinion you have to put defaultPref not pref in site.js to permit users to choose the remote address book he prefers.

Have a great day

Piviul
mmerlone

mmerlone

2013-06-03 14:24

reporter   ~0005632

Oops! Using the id value does work. Also agree with piviul, defaultPrev looks better, besides this is a per-site requirement, and that could be better stated on docs.
ludovic

ludovic

2013-06-25 13:08

administrator   ~0005713

This is already mentioned in the doc:

"Moreover, you must change the value of the sogo-integrator.autocomplete.server.urlid preference from defaults/preferences/site.js to match the identifier of your SOGoUserSources. This source will be used by Thunderbird for autocompletion."

Issue History

Date Modified Username Field Change
2013-05-15 10:17 mmerlone New Issue
2013-05-15 10:17 mmerlone File Added: 2013-05-15_11-14-58.png
2013-05-30 04:28 alessio Note Added: 0005618
2013-05-31 03:29 piviul Note Added: 0005620
2013-05-31 07:29 Christian Mack Relationship added related to 0000829
2013-05-31 07:30 Christian Mack Note Added: 0005621
2013-05-31 09:29 piviul Note Added: 0005622
2013-06-03 08:04 mmerlone Note Added: 0005625
2013-06-03 08:18 ludovic Note Added: 0005626
2013-06-03 08:25 Christian Mack Note Added: 0005627
2013-06-03 08:49 piviul Note Added: 0005628
2013-06-03 14:24 mmerlone Note Added: 0005632
2013-06-25 13:08 ludovic Note Added: 0005713
2013-06-25 13:08 ludovic Status new => closed
2013-06-25 13:08 ludovic Resolution open => won't fix