View Issue Details

IDProjectCategoryView StatusLast Update
0002361SOGoBackend Mailpublic2013-07-12 16:05
Reportersogobugreporter Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version2.0.5a 
Target VersionFixed in Version 
Summary0002361: IMAP - TLS over port 143
Description

From config: SOGoIMAPServer = "localhost:143/?tls=YES";

I check preferences after logging in, IMAP settings say port 143 and TLS enabled. But I cannot get folders to show (my inbox). So to double check, I add another account manually. Settings 143/TLS. That doesn't work either.

I run a trace/log on SOGo. And I notice this:
url=imaps://test%40domain.com@localhost:143/?tls=YES/?tls=YES

  1. /?tls=YES is concatenated onto the string from my SOGoIMAPServer setting. That doesn't look right.

  2. I notice that it's defaulting to imaps://, and it should be imap:// because it's TLS on port 143. I did an openssl s_client -starttls imap -tls1 etc., and it worked fine. Our TLS over 143 is working I believe.

  3. After I added another test account in addition to the default IMAP account associated with ldap, I noticed that when it attempted to connect, it had imaps:// also, but didnt have the double /?tls=YES like the default IMAP account did.

My belief is that it should be imap:// and not imaps:// (because that will go to 993 and I am telling the system to go to 143, so it doesn't jive)

I tested SSL over 993 and that works fine.

Additional Information

LOG OUTPUT:

Jun 30 02:11:02 sogod [29112]: <0xB0A135A8[SOGoMailAccount]:0> renewing imap4 password
2013-06-30 02:11:02.479 sogod[29112] ERROR(-[NGActiveSSLSocket primaryConnectToAddress:]): couldn't setup SSL connection on socket ...

Jun 30 02:11:02 sogod [29112]: [ERROR] <0x0x7f54b08b7b28[NGImap4ConnectionManager]> IMAP4 login failed:
host=localhost, user=test@domain.com, pwd=yes
url=imaps://test%40domain.com@localhost:143/?tls=YES/?tls=YES
base=(null)
base-class=(null))
= <0x0x7f54b08db318[NGImap4Client]: login=test@domain.com(pwd) address=<0x0x7f54b0810708[NGInternetSocketAddress]: host=localhost port=143>>
Jun 30 02:11:02 sogod [29112]: [ERROR] <0xB0A135A8[SOGoMailAccount]:0> Could not connect IMAP4

TagsNo tags attached.

Activities

neimeier

neimeier

2013-07-04 14:58

reporter   ~0005740

I use

SOGoIMAPServer = "imap://host.domain:143/?tls=YES";

and it works.

rgds
Martin

ludovic

ludovic

2013-07-12 16:05

administrator   ~0005745

The doc says that "imaps://localhost:143/?tls=YES" must be used.

Issue History

Date Modified Username Field Change
2013-06-30 02:28 sogobugreporter New Issue
2013-07-04 14:58 neimeier Note Added: 0005740
2013-07-12 16:05 ludovic Note Added: 0005745
2013-07-12 16:05 ludovic Status new => closed
2013-07-12 16:05 ludovic Resolution open => won't fix