SOGo | BTS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004700SOGoGUIpublic2019-03-12 15:072019-03-12 17:27
Reporterparavis 
Assigned Toludovic 
PriorityhighSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformMultipleOSMultipleOS VersionMultiple
Product Version4.0.5 
Target VersionFixed in Version 
Summary0004700: Varying printing issues
DescriptionPrinting from main Mail UI yields inconsistent results. Printing from popup window for mail also yields inconsistent results.
Steps To ReproduceIn Firefox, Safari and Chrome, printing from popup window gives a blank printed page. Open any email, click the "Open in New Mail Window" icon, and then print from the mail menu.

In Firefox and Chrome, printing from the main mail UI prints with content, but has the compose icon placed in a random location depending on browser. Safari does not have this issue. Open any email, click the mail menu, then "Print".
Additional InformationWe are running 4.0.5, nightly build from January 9th, 2019, not able to update at this time.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
User avatar (0013439)
francis (administrator)
2019-03-12 15:09

Too bad you can't update :(

https://github.com/inverse-inc/sogo/commit/9ebd7282156cc113825b064ca577afc269988622 [^]
(0013440)
paravis (reporter)
2019-03-12 15:09

I just realized that the blank window is resolved (https://sogo.nu/bugs/view.php?id=4674 [^]).

However, do you know if the printing from main mail UI with the compose icon is related or has been resolved in another bug fix?

We can make arrangements to upgrade the nightly build, though I don't know when we can do that.
(0013441)
paravis (reporter)
2019-03-12 17:03

Actually Francis, we ended up biting the bullet and updating to the current nightly. Not like I have time for that ... Ha ha ...

But yes, I believe that actually fixed this, for both issues I was seeing. Do you know what was causing the "Compose" pencil icon to show in the print? Is this something you are aware that was actually fixed between the January builds and current?
(0013442)
paravis (reporter)
2019-03-12 17:11

You can definitely close this. All issues definitely had been resolved. Thanks Francis :-)

- Issue History
Date Modified Username Field Change
2019-03-12 15:07 paravis New Issue
2019-03-12 15:09 francis Note Added: 0013439
2019-03-12 15:09 paravis Note Added: 0013440
2019-03-12 17:03 paravis Note Added: 0013441
2019-03-12 17:11 paravis Note Added: 0013442
2019-03-12 17:27 ludovic Status new => closed
2019-03-12 17:27 ludovic Assigned To => ludovic
2019-03-12 17:27 ludovic Resolution open => no change required


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker