View Issue Details

IDProjectCategoryView StatusLast Update
0005033SOGoBackend Mailpublic2020-05-20 11:18
Reporterdani Assigned Toludovic  
PrioritynormalSeverityblockReproducibilityhave not tried
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version6
Product Version2.3.23 
Fixed in Version2.3.24 
Summary0005033: Can't send email when using SMTP : unrecognized selector sent to instance
Description

I've upgraded an install on a CentOS6 server today (using the nightly repo). Since then, sending any email silently fails : from the web interface, no error is shown, the compose windows close just as if the email was sent, except it's not. Logs show :

May 20 14:53:06 sogod [10432]: 192.168.7.101 "GET /SOGo/so/dani/Mail/0/folderDrafts/newDraft1589979186-1/edit HTTP/1.1" 200 8972/0 0.176 27868 67% 1M
2020-05-20 14:53:16.499 sogod[10412] EXCEPTION: <NSException: 0x5598ddc4f778> NAME:NSInvalidArgumentException REASON:+[Object smtpClient]: unrecognized selector sent to instance 0x7f21663d5420 INFO:(null)
May 20 14:53:16 sogod [10432]: 192.168.7.101 "POST /SOGo/so/dani/Mail/0/folderDrafts/newDraft1589979186-1/send HTTP/1.1" 501 0/193 0.087 - - 580K

The error message is not the same as bug 0005025
(I tried anyway to reinstall sope49-mime with no effect)

Version installed :

sope49-cards-2.3.23.20200520-1.centos6.x86_64
sogo-ealarms-notify-2.3.23.20200520-1.centos6.x86_64
sope49-mime-4.9-20200514_1664.el6.1.x86_64
sope49-core-4.9-20200514_1664.el6.1.x86_64
sogo-tool-2.3.23.20200520-1.centos6.x86_64
sope49-xml-4.9-20200514_1664.el6.1.x86_64
sope49-gdl1-mysql-4.9-20200514_1664.el6.1.x86_64
sope49-appserver-4.9-20200514_1664.el6.1.x86_64
sogo-activesync-2.3.23.20200520-1.centos6.x86_64
sope49-gdl1-4.9-20200514_1664.el6.1.x86_64
sope49-sbjson-2.3.1-20200514_1664.el6.1.x86_64
sope49-gdl1-contentstore-2.3.23.20200520-1.centos6.x86_64
sope49-ldap-4.9-20200514_1664.el6.1.x86_64
sogo-2.3.23.20200520-1.centos6.x86_64

Downgrading to sope49-mime-4.9-20200429_1664.el6.1.x86_64 (only this package) fixes it. Another workaround is to use sendmail instead of SMTP

TagsNo tags attached.

Activities

the_nic

the_nic

2020-05-20 10:00

reporter   ~0014366

this is because the smtp change was not backported to the sogo v2 branch. I've opened a pull request to do this: https://github.com/inverse-inc/sogo/pull/278

Issue History

Date Modified Username Field Change
2020-05-20 09:11 dani New Issue
2020-05-20 10:00 the_nic Note Added: 0014366
2020-05-20 11:18 ludovic Assigned To => ludovic
2020-05-20 11:18 ludovic Status new => resolved
2020-05-20 11:18 ludovic Resolution open => fixed
2020-05-20 11:18 ludovic Fixed in Version => 2.3.24