View Issue Details

IDProjectCategoryView StatusLast Update
0000520SOGo Connectorwith SOGopublic2012-03-16 15:03
Reportersteve Assigned Towsourdeau 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Summary0000520: can't open/edit events with lightning 0.9.9 and connector 0.99
Description

Fresh install thunderbird 2.0.0.24 on Windows XP, install Inverse Lightning 0.9.9, install Connector 0.99. After creating remote calendar in Lightning, user cannot open or edit newly synced events. Disabling Connector allows user to edit events. Have reproduced with 2 systems.

TagsNo tags attached.

Activities

steve

steve

2010-03-24 17:28

reporter   ~0000792

In Thunderbird Error Console after attempting to open/edit event:

job.finalize is not a function line 121

chrome://calendar/content/calendar-views.js

steve

steve

2010-03-25 15:30

reporter   ~0000803

I also tried on a 3rd computer (this time Linux instead of Windows) and installed both Connector (0.99) and Integrator (0.99). With one or both installed, I cannot open or edit any event synced from server. Can create new events.

Also, I just went back to an older install of the Connector (0.97) that used to work properly. It no longer does. I cannot open or edit the events. Perhaps the problem then is something that has been introduced in SOGo itself.

steve

steve

2010-03-26 19:02

reporter   ~0000810

I guess I didn't search well enough as I just found bug 452 which appears to report the same problem. Just to see if it would help, I enabled the cache on a Connector-only system as suggested to ib_pl by ludovic. I am still unable to open or edit any event (non-local). There is an email account setup (the same one accessed by SOGo) in Thunderbird. No buttons appear to be disabled in any of my setups.

I'm not sure why any attempt to open or edit an event is producing the job.finalize error in Lightning.

ludovic

ludovic

2010-03-26 19:09

administrator   ~0000811

Have you restarted TB after enabling the cache on all calendars?

steve

steve

2010-03-26 19:31

reporter   ~0000812

Yes I did. There is only the one remote (SOGo) calendar. The other calendar is local and does not exhibit the same behavior. This is a Linux system.

I just walked over the enabled the cache on the fresh installation (Windows) and it works there.

I'm going to uninstall and re-install on the Linux system. I've tried several different versions of Lightning and the plugin. Perhaps one of the older versions wasn't fully removed.

steve

steve

2010-03-26 20:12

reporter   ~0000813

Still does not work on Linux. This time to rule out distro-specific files, I downloaded the 2.0.0.24 tarball and installed in a new directory. I also used a fresh profile.

The same error occurs. This time, I ran it from the command line. In addition to the job.finalize error I received earlier, here is what is output by thunderbird:

CalDAV: Status 207 checking ctag for calendar Work
CalDAV: recv: <?xml version="1.0" encoding="utf-8"?>
<D:multistatus xmlns:a="http://calendarserver.org/ns/&quot; xmlns:D="DAV:"><D:response><D:href>/SOGo/dav/steve@4test.net/Calendar/personal/</D:href><D:propstat><D:status>HTTP/1.1 200 OK</D:status><D:prop><a:getctag>1269645794</a:getctag></D:prop></D:propstat></D:response></D:multistatus>
CalDAV: ctag matches, no need to fetch data for calendar Work
An error occurred with one of the ACL queries, which indicates the server don't support ACL.
Code: 404
We keep the ACL entry but mark it as having no support.

ludovic

ludovic

2010-03-26 21:08

administrator   ~0000814

It works with steve@4test.net on Windoze?

steve

steve

2010-03-26 21:19

reporter   ~0000815

Correct. Same test server (1.2.1) too.

Since then, I went to my everyday Linux desktop (old Fedora 10 system). It has Thunderbird 2.0.0.23 (from distro) and non-Inverse Lightning 0.9 (from distro). I added Connector 0.99 and it works. It does take a couple of seconds (and with lots of blinking on the calendar, but it works! Could the problem be in Inverse Lightning?

ludovic

ludovic

2010-03-26 21:39

administrator   ~0000816

You MUST use the Inverse Edition. The "standard" Lightning v0.9 just won't work, it has a plethora of nasty bugs.

So, this bug can be closed?

steve

steve

2010-03-26 23:51

reporter   ~0000817

No. It works with the non-Inverse version. It does not work with the Inverse version on a fresh tarball install. That's why I thought the bug might be in Inverse Lightning.

ludovic

ludovic

2010-03-27 07:29

administrator   ~0000818

On your Fedora 10 system, with the Inverse Edition, have you installed libstdc++5?

steve

steve

2010-03-28 02:32

reporter   ~0000819

Yes. I believe that Lightning complained about it not being there and wouldn't start without it, so I installed it.

steve

steve

2010-03-30 03:25

reporter   ~0000828

I just installed again (TB 2.0.0.24, latest Inverse Lightning, Connector 0.99), this time on Windows 7 (32-bit) [note: my previous install that worked was on Vista 32-bit]. With cache turned on, I cannot open/edit event either. This is a different user, but the error message is exactly the same (job.finalize is not a function line 121).

steve

steve

2010-03-31 00:07

reporter   ~0000831

Tried a new install on WinXP (TB 2.0.0.24, latest Inverse Lightning, Connector 0.99). This does not work either.

I've gone back to see why the Vista install was working. Turns out that it was version 0.97. That's the last working version I recall. So I did a little experiment trying old versions. The best combination to be able to open/view events as well as sync the addressbooks, was Inverse Lightning 0.9.7 and Connector 0.99. Works on Linux (Fedora 10), WinXP, Win Vista (32-bit), Win7 (32-bit).

I'm not sure where the bug is, but the combination of Inverse Lightning 0.9.9 and Connector 0.99 does not work.

ludovic

ludovic

2010-04-01 16:36

administrator   ~0000846

What if you try with the following packages:

http://inverse.ca/downloads/tmp/

steve

steve

2010-04-01 17:03

reporter   ~0000847

I just tried on WinXP-32, TB 2.0.0.24, Inverse Lightning 0.10pre3, Connector 0.100pre3 and it doesn't work. It gives the same error as before when you try to open or edit an event. I'm still connecting to SOGo 1.2.1. Would it help to try nightly?

ludovic

ludovic

2010-04-01 17:04

administrator   ~0000848

Indeed, try a nightly.

steve

steve

2010-04-01 17:17

reporter   ~0000849

I just tried the current nightly, and, unfortunately, it does not work.

ludovic

ludovic

2010-04-01 17:42

administrator   ~0000850

Show us:

1- a screenshot of Thunderbird's addon window
2- all the modifications you've done to SOGo Integrator files
3- your .GNUstepDefaults
4- your Apache configuration
5- your updates.php file

steve

steve

2010-04-01 17:44

reporter   ~0000851

Remember, I'm not using Integrator. I've seen other mention that it works with Integrator. Is it required now?

2010-04-01 18:06

 

ss-tb-addon.png (Attachment missing)
ludovic

ludovic

2010-04-01 18:14

administrator   ~0000852

At least, try with it to confirm. We never do any kind of deployments without both the connector and the integrator.

steve

steve

2010-04-01 18:43

reporter   ~0000853

1-I've uploaded the screenshot to this bug report
2-n/a not using Integrator
3-.GNUstepDefaults:

{
NSGlobalDomain = {
};
gdnc = {
};
sogod = {
NGUseUTF8AsURLEncoding = YES;
OCSFolderInfoURL = "postgresql://sogo:sogo@db.4test.net:5432/sogo/so
go_folder_info";
SOGoACLsSendEMailNotifications = YES;
SOGoAppointmentSendEMailNotifications = YES;
SOGoAuthenticationMethod = LDAP;
SOGoDraftsFolderName = Drafts;
SOGoFoldersSendEMailNotifications = YES;
SOGoIMAPServer = localhost;
SOGoLanguage = English;
SOGoLoginModule = Mail;
SOGoMailDomain = 4test.net;
SOGoMailingMechanism = smtp;
SOGoOtherUsersFolderName = "Other Users";
SOGoProfileURL = "postgresql://sogo:sogo@db.4test.net:5432/sogo/sogo_user_profile";
SOGoSMTPServer = smtp.4test.net;
SOGoSentFolderName = Sent;
SOGoSharedFolderName = "Shared Folders";
SOGoSuperUsernames = (
sogo
);
SOGoTimeZone = America/Los_Angeles;
SOGoTrashFolderName = Trash;
SOGoUserSources = (
{
CNFieldName = cn;
IDFieldName = uid;
UIDFieldName = uid;
baseDN = "ou=users,dc=4test,dc=net";
bindDN = "uid=sogo,ou=users,dc=4test,dc=net";
bindPassword = ****;
canAuthenticate = YES;
displayName = "Shared Addresses";
encryption = STARTTLS;
hostname = ldap.4test.net;
id = shared;
isAddressBook = NO;
port = 389;
}
);
WOApplicationRedirectURL = "https://webmail.4test.net&quot;;
WOHttpAllowHost = (
localhost.localdomain,
localhost,
sync.4test.net
);
WOMessageUseUTF8 = YES;
WOParsersUseUTF8 = YES;
WOPort = 20000;
WOUseRelativeURLs = YES;
};
}
4-Apache config:
Alias /SOGo.woa/WebServerResources/ \
/usr/GNUstep/System/Library/SOGo/WebServerResources/
Alias /SOGo/WebServerResources/ \
/usr/GNUstep/System/Library/SOGo/WebServerResources/
AliasMatch /SOGo/so/ControlPanel/Products/(.)/Resources/(.) \
/usr/GNUstep/System/Library/SOGo/$1.SOGo/Resources/$2

<LocationMatch "^/SOGo/so/ControlPanel/Products/.UI/Resources/.jpg">
SetHandler default-handler
</LocationMatch>

<LocationMatch "^/SOGo/so/ControlPanel/Products/.UI/Resources/.png">
SetHandler default-handler
</LocationMatch>

<LocationMatch "^/SOGo/so/ControlPanel/Products/.UI/Resources/.gif">
SetHandler default-handler
</LocationMatch>

<LocationMatch "^/SOGo/so/ControlPanel/Products/.UI/Resources/.css">
SetHandler default-handler
</LocationMatch>

<LocationMatch "^/SOGo/so/ControlPanel/Products/.UI/Resources/.js">
SetHandler default-handler
</LocationMatch>
ProxyRequests Off
SetEnv proxy-nokeepalive 1
ProxyPreserveHost On
ProxyPassInterpolateEnv On
ProxyPass /SOGo http://127.0.0.1:20000/SOGo interpolate

<Proxy http://127.0.0.1:20000/SOGo>
RequestHeader set "x-webobjects-server-port" "443"
RequestHeader set "x-webobjects-server-name" "webmail.4test.net"
RequestHeader set "x-webobjects-server-url" "https://webmail.4test.net&quot;
RequestHeader set "x-webobjects-server-protocol" "HTTP/1.0"
RequestHeader set "x-webobjects-remote-host" "127.0.0.1"
Order allow,deny
Allow from all
</Proxy>
5- n/a not using Integrator

We're planning on moving to using Integrator, but I thought this should work without it.

ludovic

ludovic

2010-04-01 18:52

administrator   ~0000854

Normally it should but I'm no longer sure myself - I should ask Wolfgang.

I think we added a WebDAV sync call whenever an event is opened to make sure it hasn't changed on the server and that change is in the SOGo Integrator with ties to the Inverse Edition of Lightning. I'll request feedback from Wolfgang to double check this.

ludovic

ludovic

2010-04-01 18:52

administrator   ~0000855

Read my last note.

steve

steve

2010-04-05 16:19

reporter   ~0000867

hmmm. Everything appears to work with Integrator. Looks like they might now be dependent on one another. I installed on WinXP system and it works perfectly with the 0.9.9 IL and 0.99 Connector.

Wow, Integrator sure is nice! We had always planned to use Integrator at some point to take advantage of the ACL features, however, I can't deploy to some systems yet because of multiple non-SOGo mail accounts on some clients.

It would still be nice if Connector worked alone though for those who can't, for whatever reason, deploy Integrator. If this can't happen, I'd certainly make mention of that in the manual.

sheck

sheck

2011-02-01 12:34

reporter   ~0002066

Any results on this topic? Seems that SOGo lightning still needs SOGo Integrator to work correctly:

Using SoGo Lightning it is not possible to open/edit existing events.
CalDAV-Sync with Sogo works fine and events can be modified in sogo without problems. Creating events with lightning works, but once an event is inserted into lightning it is impossible to open/edit this event.

Server 1.3.5a on lucid 64bit.
SoGo Lightning Version 1.0b2+104i (released on November 17th 2010)
SOGo Connector Thunderbird extension Version 3.104 (released on November 17th 2010)

We just switched back to "normal" lightning. Editing events is now possible but calendars have to be configured before installing Connector. When Connector is installed it isnt possible to create CalDav Calendars anymore?!?

Sidenote: We cant use Integrator because we use shortID for LogIn and surname.name@domain.com as email (and login to email server). And docs say: First of all, the Integrator will use the same user name used to connect to the frst email server confgured in Thunderbird.

fmeynadier

fmeynadier

2011-03-08 09:31

reporter   ~0002218

Same as above... We also use logins that are not the same as the email identifiers. Moreover I read in the manual that, upon Integrator installation, my address book will be transfered to the SOGo server, and then locally deleted, which I prefer not.

So I would be quite happy with SOGo connector, if it allowed for event edition on CalDAV calendar...

fmeynadier

fmeynadier

2011-03-08 10:35

reporter   ~0002219

After a little bit of investigation...

Proposed workaround : add a trailing "/" at the end of the link given by SOGo, when copying the link into lightning's dialog box... And that works, for me at least !

I had a look at the code. When uncommenting line 619 in CalDAVACLManager.js, there is a dump of the url. Error code 404 sounds familiar enough to have a thorough look at the sent URL... and indeed, the one that was displayed seemed to lack a "/" between the path and the calendar's name.

This is not solved by the "fixURL()" function, which acts after the url is formed. There are to ways to solve this : either patch lightning so that it checks for the presence of the trailing "/" before assembling the calendar's path and the calendar's filename, or patch SOGo to add a trailing "/" to the link it gives in the right-click / properties / links to this agenda / calDAV access dialog box.

I hope this helps...

chrroessner

chrroessner

2011-03-28 10:54

reporter   ~0002301

I have the same problem, but I can not confirm the solution given by the former author. I can see a non-personal calendar, which I own, but I can not modify anything.

Lucid/64 with SOGo from the inverse-repos. Using connector and integrator from the regular download site.

I can confirm that SOGo could/should give the calendar URL with the trailing slash.

I will give the nightly builds a try and report, if this in combination with adding the slash solves it...

chrroessner

chrroessner

2011-03-28 11:00

reporter   ~0002302

Okay. Can confirm. Adding the slash and using the nightly build works for me, too.

ludovic

ludovic

2012-03-16 15:03

administrator   ~0003592

No updates in ages, closing.

Issue History

Date Modified Username Field Change
2010-03-24 17:22 steve New Issue
2010-03-24 17:28 steve Note Added: 0000792
2010-03-25 15:30 steve Note Added: 0000803
2010-03-26 19:02 steve Note Added: 0000810
2010-03-26 19:09 ludovic Note Added: 0000811
2010-03-26 19:31 steve Note Added: 0000812
2010-03-26 20:12 steve Note Added: 0000813
2010-03-26 21:08 ludovic Note Added: 0000814
2010-03-26 21:19 steve Note Added: 0000815
2010-03-26 21:39 ludovic Note Added: 0000816
2010-03-26 23:51 steve Note Added: 0000817
2010-03-27 07:29 ludovic Note Added: 0000818
2010-03-28 02:32 steve Note Added: 0000819
2010-03-30 03:25 steve Note Added: 0000828
2010-03-31 00:07 steve Note Added: 0000831
2010-04-01 16:36 ludovic Note Added: 0000846
2010-04-01 17:03 steve Note Added: 0000847
2010-04-01 17:04 ludovic Note Added: 0000848
2010-04-01 17:17 steve Note Added: 0000849
2010-04-01 17:42 ludovic Note Added: 0000850
2010-04-01 17:44 steve Note Added: 0000851
2010-04-01 18:06 steve File Added: ss-tb-addon.png
2010-04-01 18:14 ludovic Note Added: 0000852
2010-04-01 18:43 steve Note Added: 0000853
2010-04-01 18:52 ludovic Note Added: 0000854
2010-04-01 18:52 ludovic Note Added: 0000855
2010-04-01 18:52 ludovic Assigned To => wsourdeau
2010-04-01 18:52 ludovic Status new => feedback
2010-04-05 16:19 steve Note Added: 0000867
2011-02-01 12:34 sheck Note Added: 0002066
2011-03-08 09:31 fmeynadier Note Added: 0002218
2011-03-08 10:35 fmeynadier Note Added: 0002219
2011-03-28 10:54 chrroessner Note Added: 0002301
2011-03-28 11:00 chrroessner Note Added: 0002302
2012-03-16 15:03 ludovic Note Added: 0003592
2012-03-16 15:03 ludovic Status feedback => closed
2012-03-16 15:03 ludovic Resolution open => fixed