SOGo | BTS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000639SOGoBackend Generalpublic2010-05-29 18:262010-05-31 07:03
Reporterwharf 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version1.2.2 
Target VersionFixed in Version1.3.0 
Summary0000639: [SOGo 1.2.2 Nightly build]
DescriptionSorry to be so harassing but anything i could have attempt gives same results

When i use the record and quit from preferences i have a proxy 502 error with a log which looks like this :

[29/May/2010:23:55:28 GMT] "GET /SOGo/SOGo/mxxxxxx.vxxxxxxx/preferences HTTP/1.1" 200 14185/0 0.226 55275 74% 448K
EXCEPTION: <NGCouldNotConnectException: 0xa2788e0> NAME:NGCouldNotConnectException REASON:Could not connect to address <0x0xa26d940[NGInternetSocketAddress]: host=mail.toto.eu port=2000>: connection refused INFO:(nil)
<0x0x9df85a8[WOWatchDogChild]> child 3768 exited
<0x0x9df85a8[WOWatchDogChild]> (terminated due to signal 6)
SNS support disabled.
<0x0x9de7b50[WOWatchDog]> child spawned with pid 3776
<0x0x9f4a4e0[SOGoProductLoader]> SOGo products loaded from '/usr/GNUstep/System/Library/SOGo':
<0x0x9f4a4e0[SOGoProductLoader]> Appointments.SOGo, PreferencesUI.SOGo, Contacts.SOGo, Mailer.SOGo, MailerUI.SOGo, MainUI.SOGo, AdministrationUI.SOGo, CommonUI.SOGo, ContactsUI.SOGo, MailPartViewers.SOGo, SchedulerUI.SOGo
|SOGo| version 1.2.2 (build root@vizzini.inverse.ca 201005280642) -- starting
|SOGo| vmem size check enabled: shutting down app when vmem > 384 MB
Additional InformationSeems it crashes when showing proxy error 502 and respawn ?

I've opened the all the ports on the firewall on the imap server to allow sogo server to reach any remote ports.
It seems that SOGo is initiating something on the port 2000.

I tried to connect using thunderbird to the imap server and it is ok.

As side effect i noticed this in the logs when opening the mail menu

[NGImap4Client]: login=mxxxxx.vxxxxx@toto.eu(pwd) socket=<NGActiveSocket[0x0xa03f078]: mode=rw address=<0x0x9fbe0f0[NGInternetSocketAddress]: host=ssandbox.toto.eu port=43058> connectedTo=<0x0xa1ac638[NGInternetSocketAddress]: host=mail.toto.eu port=143>>>
<0x0A09AA20[SOGoMailFolder]:folderINBOX> renewing imap4 password
<0x0x9fec7a0[NGImap4ConnectionManager]> IMAP4 login failed:
  host=mail.toto.eu, user=mxxxxxx.vxxxxx@toto.eu, pwd=yes
  url=imap://mxxxxxx.vxxxxxx%40toto.eu@mail.toto.eu/INBOX/
  base=(nil)
  base-class=(nil))
  = <0x0xa25f308[NGImap4Client]: login=mxxxxx.vxxxxxx@toto.eu(pwd) socket=<NGActiveSocket[0x0x9d38018]: mode=rw address=<0x0xa19c8a0[NGInternetSocketAddress]: host=ssandbox.toto.eu port=43059> connectedTo=<0x0xa18fa00[NGInternetSocketAddress]: host=mail.toto.eu port=143>>>
<0x0A09AA20[SOGoMailFolder]:folderINBOX> Could not connect IMAP4


Is this normal ? -----------> url=imap://mxxxxxx.vxxxxxx%40toto.eu@mail.toto.eu/INBOX/

looks like a bad formed address to me


Again thank you and sorry to be that annoying
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0001079)
wharf (reporter)
2010-05-31 04:40

I found why the mail address was badly formed, due to this in the GNUstepDefaults

SOGoForceIMAPLoginWithEmail = YES

should be in my case to NO
 
Still getting proxy error 502 and sogo still wants to access to port 2000 but i can't figure what is the relation with "saving preferences" and sogo attempting to access to this port.

GNUstepDefaults looks like this now

{
    NSGlobalDomain = {
    };
    sogod = {
        SOGoSMTPServer = "smtp.toto.eu";
        OCSFolderInfoURL = "mysql://sogo:pss@localhost:3306/sogo/sogo_folder_info";
        SOGoACLsSendEMailNotifications = YES;
        #SOGoAppointmentSendEMailNotifications = YES;
        SOGoAuthenticationMethod = LDAP;
        SOGoDraftsFolderName = Drafts;
        SOGoFirstDayOfWeek = 1;
        SOGoFoldersSendEMailNotifications = YES;
        SOGoForceIMAPLoginWithEmail = NO;
        SOGoForwardEnabled = YES;
        SOGoIMAPServer = "pop.toto.eu";
        SOGoLanguage = French;
        SOGoMailDomain = "toto.eu";
        SOGoMailingMechanism = smtp;
        SOGoProfileURL = "mysql://sogo:pss5@localhost:3306/sogo/sogo_user_profile";
        SOGoSentFolderName = Sent;
        SOGoSuperUsernames = (
            usr,
            user,
            root
        );
        SOGoTimeZone = Europe/Paris;
        SOGoTrashFolderName = Trash;
        SOGoUserSources = (
            {
                CNFieldName = cn;
                IDFieldName = uid;
                UIDFieldName = uid;
                baseDN = "dc=toto,dc=net";
                bindDN = "cn=manager,dc=toto,dc=net";
                bindFields = uid;
                bindPassword = xxxxx;
                canAuthenticate = YES;
                displayName = "Contacts communs";
                hostname = 192.168.1.250;
                id = public;
                isAddressBook = YES;
                port = 389;
                type = ldap;
            }
        );
        SOGoVacationEnabled = YES;
        WOApplicationRedirectURL = "https://192.168.1.251/SOGo"; [^]
        WOMessageUseUTF8 = YES;
        WOParsersUseUTF8 = YES;
        WOPort = 20000;
        WOSendMail = smtp;
    };
}
(0001081)
wharf (reporter)
2010-05-31 04:55

I got it !
This is not a bug.

SOGoVacationEnabled = YES;
SOGoForwardEnabled = YES;

Those are requiring sieve to be activated which is not at present time on the remote server. I deactivated them until i get sieve working on the remote mail server.
Thanks a lot for the hint about sieve.
This case can be closed.

- Issue History
Date Modified Username Field Change
2010-05-29 18:26 wharf New Issue
2010-05-31 04:40 wharf Note Added: 0001079
2010-05-31 04:55 wharf Note Added: 0001081
2010-05-31 07:03 ludovic Status new => closed
2010-05-31 07:03 ludovic Resolution open => no change required
2010-05-31 07:03 ludovic Fixed in Version => 1.2.3


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker